[SOLVED]OSC not finding submodules

I upgraded to Monterey, everything was fine for a few days, although I would get a message that port 5000 was in use, so i moved that port to 5001 or 5010. Today Im getting lost submodules. Everything is in the right place, and I didn’t change anything. I have updated OSC but no joy

(ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/json/artificialharmonics.com_flow+_json.js

(ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/artificialharmonics.com_flow+_ui.js

(ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/explorer/artificialharmonics.com_flow+_explorer.js

(ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/content/artificialharmonics.com_flow+_content.js

(ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/bottom/artificialharmonics.com_flow+_bottom.js

(ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/search/artificialharmonics.com_flow+_search.js

(ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/artificialharmonics.com_flow+_static.js (ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/api/artificialharmonics.com_flow+_api.js (ERROR) Submodule not found: /Users/DrCWebber/Music/Flow+ 1.1.0/js/js/functions/artificialharmonics.com_flow+_import.js
Screen Shot 2022-06-02 at 7.51.55 am

Hi Colin,
this seems an error that states the source files are not located in the right folder, or it might be you have put them in a folder with restricted access so the program cannot get to them

suggestion
take the source code from the download area and copy them into a new folder outside of the users one

Marco

Thanks Marco
I re-downloaded Flow+, put it all on an external disk to avoid the User folder, ensured read/write permissions, but the same issue comes. This has occurred since I update to monterey, but strangely, it worked fine for a few days. The Port issue also persists

I am still seeking a solution for this. I have colpetley reinstalled both OSC and Flow, into a shared drive, checked permissions etc… and submitted a help request 9 no reply) and the problem persists

I found and deleted all OSC preferences - I had two sets in different places. If I use port 5000 I get a port already in use error. If i use a different port, eg 5010, 5050, I get an invalid port undefined error when I try to switch on a module. If I then stop and restart the server with different port, I get (ERROR) Submodule not found: /Volumes/Colins Samples/Flow+ 1.1.0/js/artificialharmonics.com_flow+.js

Hi There
so the issue is linked to an update of OSC that now needs a fix in Flow
I will plan this release for the month of August, till then just make sure to not upgrade OSC

version up to 1.15.7 works

Marco