[SOLVED] Flow2 Communication Issues (For Articulations/Expression maps only)

Hi Marco,

I’m having problems with the articulations not being sent back to flow 2 for tracks in cubase 13. im using flow 2.5.0. Track filtering is working fine. Im not getting an articulation list being sent back to the flow app and I wonder if something is wrong with my setup?
I just get ‘no object selected’ on picking any midi track. I have auto arm record selected in the cubase settings.
Here are my generic remote setups as requested.

Many thanks,


In my cubase project that comes with Flow 2.5.0… The midi transformer on all the midi tracks in the project is still showing ‘value 1’ and ‘value 2’ rather than subtype and main value. Im on windows 10 and cubase 13.0.10.

Hi Edward

Generic remotes seems fine,
One possible issue is that sometimes (and mostly for Mac users) when you first open cubase it says that there is a missing port which you need to remap manually, was this your case?

To check that, you could make a test and download again the cubase project from the download package, if this message appears map it manually (the one with the same name)

Also can you select any track and send a screenshot of the midi transformer? To see if the right midi port is in use


Yes this is ok
The fix I have made has changed the json file and not cubase, so do not worry about it!


Hi Marco,

Thanks for looking at this for me.

I didn’t get any port messages no. I know the dialogue box you mean.
Here are a few more screenshots for you. I’ve downloaded the project file again and its still the same. No error message on opening.

Thanks for the info Edward,

one last thing before we setup a video call, is there any error in the Open Stage Control server?
just enable the debug option before launching it and see if any debug error appears in the log

let me know!

Hi Marco thanks again for help.

Just a few debug things marked in red…

Are these marked to show midi out rather than errors?
No specific errors in which case.
at the end of the long instrument definitions

(DEBUG, OSC) Out: {
address: ‘/activate/track/master’,
args: [ { type: ‘f’, value: 1 } ]
} To: localhost:3000

and when pressing the green activate button to to to enable;

(DEBUG, MIDI) out: CONTROL_CHANGE: channel=1, cc=125, value=1 To: midi:flow

Hopefully these are just red as they are outs!

Just out of interest I had to rename the folder Flow+ 1.3.0 to Flow+1.3.0 (removing the space) to get OSC to find the .json .css and .js on windows. It seemed to interpret the space and the + as an argument after a command. removing the space fixed the issue.

I tried looking at the data import too. It still says in the article to do it but not in the video. Flow 2 Installation guide

Just experimentally to see if theres any weirdness there;
Interestingly data import could not find any data files in any folder I tried.

Also; the activate instrument and deativate button does not work.
heres a screen grab of debug when sending enable instrument ;

I copied the midi setup text exactly from the setup guide. :thinking:

Cheers! Ed

Hi Edward

I think is best to setup a cal at this time :grinning:

I am sure is a simple thing and we will find it out quickly, while here we are just turning around!

I will contact you via email to set it up!


No problem at all… this might be helpful…

Notice the path is messed up with / and \ ?

Ok so the problem might be that the data was not correctly loaded, cause he does not find the files where they should be
it is ok that the path is a mix of / and \

are you in Windows or Mac?

did you manage to do the import as described here? Do you have a message that the data was imported and you need to restart?

What does it happen when you click on the on/off button that is top right in each of the three top tabs?

now there is maybe a problem here; the import feature can’t find any files at all.

Im in windows and I can’t get the data import to work at all im afraid.
The on/off buttons do wrk for the top panels only.

Hi edward

This is not the right folder to use
You need to point to the content which is in the flow.cv professional template not the flow+ app

Please look at the example which is given in the window below the input, paste that folder and click enter

I believe in the end, this is just the issue

Let me know

Hi Marco,

That helped with the data loading but it is still not working unfortunately, It found the data and I was able to load it all.
It’s still not showing articulations or allowing the activate switch to work unfortunately.

Thanks, Ed

Just in case, I thought I would clarify what I believe to be the proper working of Flow+ (please correct me if wrong): The bottom windows in Flow+ are only populated with data after you have clicked on a track in the cubase template. Once you do click on a track, you can then activate the VST in VEP by clicking on the green button, apply articulations, etc…or deactivate it if it is already active.

I explored this because at one point, because for some unknown reason, one of the generic remote files was deleted by cubase and this stopped working. I had to troubleshoot the problem and re-import the generic remote file. If you have selected a cubase track, and are still seeing nothing, you might check to see that all of the remote files are still in place in you studio setup window (generic remotes, track remotes, etc).

1 Like

That’s perfectly right Mark

in the end there is nothing exotic in the setup of Flow, It is just using the very basic MIDI communication and generic remote features of Cubase :slight_smile:

So, if it does not work the reason is confined to 2 or 3 setup issues!


HI Mark and Marco,

Thanks both for your messages and suggestions. I’ve tried replacing all the generic remotes as you suggested, deleting them and recreating them but its still not working im afraid. I select a midi track and theres nothing being transmitted out of cubase to the Flow app it seems.

Ill drop you an email Marco,



SOLVED: Thanks Marco!!

It turned out that I had disabled all the In ‘All Midi’ inputs for the flow ports. This with midi thru enabled and the track midi transformers is how expression maps/Articulations are communicated between Cubase and Flow. Turning these back on fixed the issue for me.

:slight_smile: All fixed and a note added the manual by Marco to check this is enabled.

1 Like